#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[-._]|(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])"
Local $sString = "allow-nonxdr-writes" & @CRLF & _
"io.native.lib.available" & @CRLF & _
"ha.zookeeper.parent-znode" & @CRLF & _
"min_file_size" & @CRLF & _
"ProxyStatus" & @CRLF & _
"ProxyFCGIBackendType" & @CRLF & _
"SessionDBDCookieRemove" & @CRLF & _
"DBDriver" & @CRLF & _
"SSLOCSPDefaultResponder" & @CRLF & _
"helloWorldABCdEF"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)