import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-._]|(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])";
final String string = "allow-nonxdr-writes\n"
+ "io.native.lib.available\n"
+ "ha.zookeeper.parent-znode\n"
+ "min_file_size\n"
+ "ProxyStatus\n"
+ "ProxyFCGIBackendType\n"
+ "SessionDBDCookieRemove\n"
+ "DBDriver\n"
+ "SSLOCSPDefaultResponder\n"
+ "helloWorldABCdEF";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}