import re
regex = re.compile(r"[-._]|(?<=[a-z])(?=[A-Z])|(?<=[A-Z])(?=[A-Z][a-z])", flags=re.MULTILINE)
test_str = ("allow-nonxdr-writes\n"
"io.native.lib.available\n"
"ha.zookeeper.parent-znode\n"
"min_file_size\n"
"ProxyStatus\n"
"ProxyFCGIBackendType\n"
"SessionDBDCookieRemove\n"
"DBDriver\n"
"SSLOCSPDefaultResponder\n"
"helloWorldABCdEF")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)