import re
regex = re.compile(r"^(?:|(https?:\/\/)?(|www)[.]?((t|telegram)\.me)\/)[a-zA-Z0-9_]{5,32}$", flags=re.MULTILINE)
test_str = ("https://telegram.me/opensid\n"
"http://telegram.me/opensid\n"
"www.telegram.me/opensid\n"
"telegram.me/opensid\n"
"www.t.me/opensid\n"
"t.me/opensid\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")