re = /^(?:|(https?:\/\/)?(|www)[.]?((t|telegram)\.me)\/)[a-zA-Z0-9_]{5,32}$/m
str = 'https://telegram.me/opensid
http://telegram.me/opensid
www.telegram.me/opensid
telegram.me/opensid
www.t.me/opensid
t.me/opensid
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end