package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)HELLO\[[0-9]+\]_[a-zA-Z]+\.[0-9a-fA-F]{3}`)
var str = `HELLO[345]_something.123
HELLO[23]_BlaBla.FFF
HELLO[]_.123
HELLO[1]_foo.0aC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}