const regex = /HELLO\[[0-9]+\]_[a-zA-Z]+\.[0-9a-fA-F]{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('HELLO\\[[0-9]+\\]_[a-zA-Z]+\\.[0-9a-fA-F]{3}', 'gm')
const str = `HELLO[345]_something.123
HELLO[23]_BlaBla.FFF
HELLO[]_.123
HELLO[1]_foo.0aC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}