$re = '/HELLO\[[0-9]+\]_[a-zA-Z]+\.[0-9a-fA-F]{3}/m';
$str = 'HELLO[345]_something.123
HELLO[23]_BlaBla.FFF
HELLO[]_.123
HELLO[1]_foo.0aC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);