use strict;
my $str = 'HELLO[345]_something.123
HELLO[23]_BlaBla.FFF
HELLO[]_.123
HELLO[1]_foo.0aC';
my $regex = qr/HELLO\[[0-9]+\]_[a-zA-Z]+\.[0-9a-fA-F]{3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}