using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Running module\s[a-zA-Z]+.$";
string input = @"25.5.2018 10:42:35.621 Status message 0884:Running module SamplesSim.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}