re = /Running module\s[a-zA-Z]+.$/m
str = '25.5.2018 10:42:35.621 Status message 0884:Running module SamplesSim.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end