const regex = /Running module\s[a-zA-Z]+.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Running module\\s[a-zA-Z]+.$', 'gm')
const str = `25.5.2018 10:42:35.621 Status message 0884:Running module SamplesSim.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}