using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=""(?:row|[^""]* row)(?![^"" ])[^""]*""";
string input = @"class=""foo_bar bar row test""
class=""row""
class=""hello foo bar row""
class="" foo bar row test ""
class=""hello"" row
class=""narrow""
class=""rowdy""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}