const regex = /class="(?:row|[^"]* row)(?![^" ])[^"]*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class="(?:row|[^"]* row)(?![^" ])[^"]*"', 'gm')
const str = `class="foo_bar bar row test"
class="row"
class="hello foo bar row"
class=" foo bar row test "
class="hello" row
class="narrow"
class="rowdy"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}