$re = '/class="(?:row|[^"]* row)(?![^" ])[^"]*"/m';
$str = 'class="foo_bar bar row test"
class="row"
class="hello foo bar row"
class=" foo bar row test "
class="hello" row
class="narrow"
class="rowdy"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);