re = /class="(?:row|[^"]* row)(?![^" ])[^"]*"/m
str = 'class="foo_bar bar row test"
class="row"
class="hello foo bar row"
class=" foo bar row test "
class="hello" row
class="narrow"
class="rowdy"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end