const regex = /^(?:(?:[,"\n]|"[^"]*"),){2}\K".*?"(?=(?:,(?:[,"\n]|"[^"]*")){2}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[,"\\n]|"[^"]*"),){2}\\K".*?"(?=(?:,(?:[,"\\n]|"[^"]*")){2}$)', 'gm')
const str = `"Test","test","test1234","",""
"Test","test","test1234","url_test.com/test",""
"Test","test","test1234","","testing"
"Test","test","test12"34","",""
"Test","test","te\\"st1234","",""
"Test","test","test1"2,34","",""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}