import re
regex = re.compile(r"^(?:(?:[,\"\n]|\"[^\"]*\"),){2}\K\".*?\"(?=(?:,(?:[,\"\n]|\"[^\"]*\")){2}$)", flags=re.MULTILINE)
test_str = ("\"Test\",\"test\",\"test1234\",\"\",\"\"\n"
"\"Test\",\"test\",\"test1234\",\"url_test.com/test\",\"\"\n"
"\"Test\",\"test\",\"test1234\",\"\",\"testing\"\n"
"\"Test\",\"test\",\"test12\"34\",\"\",\"\"\n"
"\"Test\",\"test\",\"te\\\"st1234\",\"\",\"\"\n"
"\"Test\",\"test\",\"test1\"2,34\",\"\",\"\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")