using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/www\.bugaboo\.com\/(at|be|cz|de|dk|es|fi|fr|gb|hr|hu|ie|it|lu|nl|pt|se|si|sk)\-.{2}\/.*\/bugaboo-fox-2\/.*bugaboo-fox-2-.*\.html";
string input = @"https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/fr-fr/poussettes/bugaboo-fox-2/poussette-naissance-et-2e-age-bugaboo-fox-2-PM001601.html
https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}