import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/www\\.bugaboo\\.com\\/(at|be|cz|de|dk|es|fi|fr|gb|hr|hu|ie|it|lu|nl|pt|se|si|sk)\\-.{2}\\/.*\\/bugaboo-fox-2\\/.*bugaboo-fox-2-.*\\.html";
final String string = "https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html\n\n"
+ "https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html\n\n"
+ "https://www.bugaboo.com/fr-fr/poussettes/bugaboo-fox-2/poussette-naissance-et-2e-age-bugaboo-fox-2-PM001601.html\n\n"
+ "https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}