$re = '/https:\/\/www\.bugaboo\.com\/(at|be|cz|de|dk|es|fi|fr|gb|hr|hu|ie|it|lu|nl|pt|se|si|sk)\-.{2}\/.*\/bugaboo-fox-2\/.*bugaboo-fox-2-.*\.html/m';
$str = 'https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/fr-fr/poussettes/bugaboo-fox-2/poussette-naissance-et-2e-age-bugaboo-fox-2-PM001601.html
https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);