// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/www\.bugaboo\.com\/(at|be|cz|de|dk|es|fi|fr|gb|hr|hu|ie|it|lu|nl|pt|se|si|sk)\-.{2}\/.*\/bugaboo-fox-2\/.*bugaboo-fox-2-.*\.html").unwrap();
let string = "https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/fr-fr/poussettes/bugaboo-fox-2/poussette-naissance-et-2e-age-bugaboo-fox-2-PM001601.html
https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}