const regex = /(.*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)_(\\d{8})_(NOZ\\d{7})_(\\d{2}.\\d{2}.\\d{4})', 'g')
const str = `Hans Wurst_12345678_NOZ1234567_24.04.2018
peterf_12345678_NOZ1234567_12.06.2017
Hans Joachim Wurst_12345678_NOZ1234567_24.04.2018
Hans Joachim Wurst GmbH_12345678_NOZ1234567_24.04.2018
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);