# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})"
test_str = ("Hans Wurst_12345678_NOZ1234567_24.04.2018\n"
"peterf_12345678_NOZ1234567_12.06.2017\n"
"Hans Joachim Wurst_12345678_NOZ1234567_24.04.2018\n"
"Hans Joachim Wurst GmbH_12345678_NOZ1234567_24.04.2018\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.