// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})").unwrap();
let string = "Hans Wurst_12345678_NOZ1234567_24.04.2018
peterf_12345678_NOZ1234567_12.06.2017
Hans Joachim Wurst_12345678_NOZ1234567_24.04.2018
Hans Joachim Wurst GmbH_12345678_NOZ1234567_24.04.2018
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}