$re = '/(.*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})/';
$str = 'Hans Wurst_12345678_NOZ1234567_24.04.2018
peterf_12345678_NOZ1234567_12.06.2017
Hans Joachim Wurst_12345678_NOZ1234567_24.04.2018
Hans Joachim Wurst GmbH_12345678_NOZ1234567_24.04.2018
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;