#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*)(?<=\s)(test(?:\s+)?\()(?:.*)$"
Local $sString = "This is a test() function" & @CRLF & _
"This is a test () function" & @CRLF & _
"test()" & @CRLF & _
"test ()" & @CRLF & _
"test(" & @CRLF & _
"matchtest()" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"The requirement is to see the word starts with space or is the first word of a line and has an open bracket "(" after that particular word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")