$re = '/^(?:.*)(?<=\s)(test(?:\s+)?\()(?:.*)$/m';
$str = 'This is a test() function
This is a test () function
test()
test ()
test(
matchtest()
The requirement is to see the word starts with space or is the first word of a line and has an open bracket "(" after that particular word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);