re = /^(?:.*)(?<=\s)(test(?:\s+)?\()(?:.*)$/m
str = 'This is a test() function
This is a test () function
test()
test ()
test(
matchtest()
The requirement is to see the word starts with space or is the first word of a line and has an open bracket "(" after that particular word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end