const regex = /^(?:.*)(?<=\s)(test(?:\s+)?\()(?:.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*)(?<=\\s)(test(?:\\s+)?\\()(?:.*)$', 'gm')
const str = `This is a test() function
This is a test () function
test()
test ()
test(
matchtest()
The requirement is to see the word starts with space or is the first word of a line and has an open bracket "(" after that particular word`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}