using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^_?[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*_?$";
string input = @"H_i_there
_this_is_OK_
_x_y_5_z
abddd_cdxxx
Not accepted:
s___2
__s__t__2
__x____x4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}