const regex = /^_?[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*_?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^_?[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*_?$', 'gm')
const str = `H_i_there
_this_is_OK_
_x_y_5_z
abddd_cdxxx
Not accepted:
s___2
__s__t__2
__x____x4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}