$re = '/^_?[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*_?$/m';
$str = 'H_i_there
_this_is_OK_
_x_y_5_z
abddd_cdxxx
Not accepted:
s___2
__s__t__2
__x____x4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);