import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^_?[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*_?$";
final String string = "H_i_there\n"
+ "_this_is_OK_\n"
+ "_x_y_5_z\n"
+ "abddd_cdxxx\n"
+ "Not accepted:\n\n"
+ "s___2\n"
+ "__s__t__2\n"
+ "__x____x4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}