using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<host>.*?) - (?P<username>\w+) \[(?P<date>[^][]*)] ""(?P<req>GET [^""]+)""";
string input = @"219.133.7.154 - price5585 [21/Jun/2019:15:45:53 -0700] ""GET /incubate/incubate HTTP/1.1"" 201 12126
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}