package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<host>.*?) - (?P<username>\w+) \[(?P<date>[^][]*)] "(?P<req>GET [^"]+)"`)
var str = `219.133.7.154 - price5585 [21/Jun/2019:15:45:53 -0700] "GET /incubate/incubate HTTP/1.1" 201 12126
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}