import re
regex = re.compile(r"(?P<host>.*?) - (?P<username>\w+) \[(?P<date>[^][]*)] \"(?P<req>GET [^\"]+)\"", flags=re.MULTILINE)
test_str = ("219.133.7.154 - price5585 [21/Jun/2019:15:45:53 -0700] \"GET /incubate/incubate HTTP/1.1\" 201 12126\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")