re = /(?P<host>.*?) - (?P<username>\w+) \[(?P<date>[^][]*)] "(?P<req>GET [^"]+)"/m
str = '219.133.7.154 - price5585 [21/Jun/2019:15:45:53 -0700] "GET /incubate/incubate HTTP/1.1" 201 12126
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end