import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "X.*";
final String string = "A-B-1_u\n"
+ "A-B-2_u\n"
+ "A-B-3_u\n"
+ "A-B-4_u\n"
+ "A-B-5_u\n"
+ "X-Y1\n"
+ "X-Y1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}