import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s]*[a-z][^\\s][.{1}][^\\s\\b]*[a-z][^.\\b][^\\s\\b]$";
final String string = "test.com\n"
+ "www.alexan.com\n"
+ "wander.economical.badnc.edu.org\n"
+ "https://website.com\n"
+ "wad.\n"
+ "wanders\n"
+ "WAD.ness\n"
+ "ww w.edu catio n.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}