import re
regex = re.compile(r"^[^\s]*[a-z][^\s][.{1}][^\s\b]*[a-z][^.\b][^\s\b]$", flags=re.MULTILINE)
test_str = ("test.com\n"
"www.alexan.com\n"
"wander.economical.badnc.edu.org\n"
"https://website.com\n"
"wad.\n"
"wanders\n"
"WAD.ness\n"
"ww w.edu catio n.net")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")