re = /^[^\s]*[a-z][^\s][.{1}][^\s\b]*[a-z][^.\b][^\s\b]$/m
str = 'test.com
www.alexan.com
wander.economical.badnc.edu.org
https://website.com
wad.
wanders
WAD.ness
ww w.edu catio n.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end