using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+(?:-\d+)?,?)+";
string input = @"1,2,3,4-7,22-30,32,31 - valid
1,2,3,4-7,22-30,32,31,1-10 - invalid as some are overlapping with other
33,45,33-45,3345 - invalid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}