import re
regex = re.compile(r"(?:\d+(?:-\d+)?,?)+", flags=re.MULTILINE)
test_str = ("1,2,3,4-7,22-30,32,31 - valid\n\n"
"1,2,3,4-7,22-30,32,31,1-10 - invalid as some are overlapping with other\n\n"
"33,45,33-45,3345 - invalid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")