re = /(?:\d+(?:-\d+)?,?)+/m
str = '1,2,3,4-7,22-30,32,31 - valid
1,2,3,4-7,22-30,32,31,1-10 - invalid as some are overlapping with other
33,45,33-45,3345 - invalid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end