package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d+(?:-\d+)?,?)+`)
var str = `1,2,3,4-7,22-30,32,31 - valid
1,2,3,4-7,22-30,32,31,1-10 - invalid as some are overlapping with other
33,45,33-45,3345 - invalid`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}