using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=EA1=)[\d\.]++";
string input = @"EA1=6.91ma EA2=0.0ma EA3=0.0ma EA4=0.0ma EA5=0.0ma EA6=0.0ma";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}