use strict;
my $str = 'EA1=6.91ma EA2=0.0ma EA3=0.0ma EA4=0.0ma EA5=0.0ma EA6=0.0ma';
my $regex = qr/(?<=EA1=)[\d\.]++/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}