re = /(?<=EA1=)[\d\.]++/m
str = 'EA1=6.91ma EA2=0.0ma EA3=0.0ma EA4=0.0ma EA5=0.0ma EA6=0.0ma'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end