const regex = /(?<=EA1=)[\d\.]++/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=EA1=)[\\d\\.]++', 'gm')
const str = `EA1=6.91ma EA2=0.0ma EA3=0.0ma EA4=0.0ma EA5=0.0ma EA6=0.0ma`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}